bitsinfo

Tire suas dúvidas e compartilhe seu conhecimento.
 
InícioInício  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Problemas com Apache2* no OpenSuse 10.2

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
sergioalsp



Mensagens : 5
Data de inscrição : 26/08/2007

MensagemAssunto: Problemas com Apache2* no OpenSuse 10.2   Dom Ago 26, 2007 11:45 pm

Problemas com Apache2* no OpenSuse 10.2


Boa Noite Gente,

Implementei um servidor apache em uma empresa e estou tendo dificuldades para implementar o virtual hosts e gostaria de saber como faço para que ao usuario digitar no brouser EX: www.meudominio.com.br ele seja redirecionado para www.meudominio.br/public_html/index.html alguem poderia me ajudar?

Segue abaixo meu arquivo vitual hosts:

#meudominio
NameVirtualHost *:80
ServerAdmin sergioalsp@gmail.com
DocumentRoot /home/www/meudominio/public_html
Servername www.meudominio.com.br
ErrorLog /home/www/meudominio/public_html/error.log
TransferLog /home/www/meudominio/public_html/access.log
<Directory /home/www/meudominio/public_html>
AllowOverride None
Order allow,deny
Allow from all
</Directory>


Ajudem-me!!!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
NotFound

avatar

Mensagens : 1
Data de inscrição : 27/08/2007

MensagemAssunto: Problemas com Apache2* no OpenSuse 10.2   Seg Ago 27, 2007 5:18 pm

Bom Dia sergioalsp

É o sequinte:

Para uma ajuda mais pertinete é necessario que você seja mais especifico.
Como por exemplo informando se seu ip é dinamico ou estatico (por favor não precisamos que você coloque seu ip aqui)e se o hostvirtual sera configurado para intranet, internet ou ambos, já que para cada um existe suas particularidades ....

seja mais claro em sua pergunta !


ABRAÇO !!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
sergioalsp



Mensagens : 5
Data de inscrição : 26/08/2007

MensagemAssunto: IP   Seg Ago 27, 2007 9:49 pm

Sim... meu ip é fixo... eu consegui redirecionar para pasta que eu queria, só que eu tenho vários dominios virtuais e só está redirecionando para um deles EX:

Tanto faz eu digitar www.meudominio.com.br(dominio1) e www.meudominio2.com.br(dominio2) ambos redirecionam para a mesma pasta. O conf do virtual host está redirecionando cada dominio para sua pasta só que o apache não tá exergando isso...


Sabe o que devo fazer?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
sergioalsp



Mensagens : 5
Data de inscrição : 26/08/2007

MensagemAssunto: Solução do redirecionamento de pastas   Seg Ago 27, 2007 9:50 pm

Voltar ao Topo Ir em baixo
Ver perfil do usuário
sergioalsp



Mensagens : 5
Data de inscrição : 26/08/2007

MensagemAssunto: Solução do problema Virtual Host   Seg Ago 27, 2007 10:20 pm

Olá galera consegui resolver o problema....

Todo o problema do apache não está entendendo o meu conf do virtual host era que tando no DocumentRoot e Directory ambos estavam apontanto para public_html

Segue abaixo a correção do problema:

#Dominio1

<VirtualHost www.meudominio.com.br:80>
ServerAdmin webmaster@gmail.com
Servername www.meudominio.com.br
DocumentRoot /home/www/dominio/public_html/
<Directory /home/www/dominio/>


#Dominio2
<VirtualHost www.meudominio2.com.br:80>
ServerAdmin webmaster@gmail.com
Servername www.meudominio2.com.br
DocumentRoot /home/www/dominio2/public_html/
<Directory /home/www/dominio2/>




Aff... sofi bastante para descobrir o problema me referenciel no Guia Foca Linux URL: http://focalinux.cipsga.org.br/guia/avancado/ch-s-apache.htm#s-s-apache-vhosts-nome
Voltar ao Topo Ir em baixo
Ver perfil do usuário
sergioalsp



Mensagens : 5
Data de inscrição : 26/08/2007

MensagemAssunto: Agradecimentos   Seg Ago 27, 2007 10:29 pm

Olá Galera gostaria de agradecer pelo apoio mais especificamente ao Marlo e o Not found.....





Obrigadoooooooooooooooooooooo!!!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Problemas com Apache2* no OpenSuse 10.2   

Voltar ao Topo Ir em baixo
 
Problemas com Apache2* no OpenSuse 10.2
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Problemas com colorir fundo
» Problemas com cores de títulos em css
» Problemas no ' sub endereço '
» Problemas com visualização de páginas HTML
» Problemas com a pré-visualização

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
bitsinfo :: Linux :: Instalação-
Ir para: